Router Interfaces (اینترفیس روتر)
پیکربندی interface یکی از مهمترین پیکربندیهای روتر است زیرا بدون interfaceها کاملا یک شی بدون استفاده میباشد.به علاوه پیکربندی interface ها باید کاملا دقیق باشد تا توانایی ارتباط با دیگر ابزارها را داشته باشد

ایجاد پیکربندی بر روی یک interface
برای پیکربندی آدرسهای IP روی یک interface از فرمان ip address در interface mode استفاده میکنیم
فراموش نکنید روشن کردن interface را با استفاده از فرمان no shutdown

 

کابل کنسول روتر

 

 

Router>en
Router#config t
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shutdown or no shut
Router(config-if)#^Z
Router#wr

در اینجا یاد آور میشوم که به فرمان ( show interface e0 ( sh int e0  دقت کنید تا مشاهده کنید,interface shutdown است یا خیر همچنین فرمان show run همین اطلاعات را به ما میدهد

 


 

 پیکربندی Serial Interface
قبل از اینکه به سراغ پیکربندی serial interface برویم باید مقداری اطلاعات در این زمینه داشته باشید
اگر بخواهیم دو روتر را که مجاور هم هستند به هم متصل کنیم باید از cross over cable استفاده کنیم . این کابل از دو پورت سریال تشکیل شده است که در ظاهر شبیه به هم هستند اما دو اسم مختلف دارند و باید تنظیمات خاص خود را در روتری که به آن متصل هستند انجام دهیم.اسم آنها به قرار زیر میباشد

کابل سریال روتر

DTE(Data Communication Equipment)
DCE(Data Terminal Equipment)

برای پیکربندی DCE interface از فرمان clock rate استفاده میکنیم
clock rate سرعت را بر حسب بیت بر ثانیه تعیین میکند
با توجه به سرعت اتصال میتوانیم سرعتهای زیر را قرار دهیم

56000
64000
72000
125000

Router>en
Router#config t
Router(config-if)#clock rate 64000

توجه داشته باشید بوسیله help میتوانید تمامی clock rate را ببنید

Router(config-if)#clock rate ?

برای مشاهده اینکه کدام DCE است و کدام DTE از فر مان زیر استفاده میکنیم البته توجه داشته باشید که بر روی کابل هم مشخص شده است

Router>en
Router#show controllers s0
or
Router#sh controllers s 0

DTE پهنای باند را مشخص میکند و بصورت پیشفرض تعیین شده است و نیازی به پیکربندی ندارد



Routing
فرآیند هدایت بسته ها در بین شبکه ها از مبدا به مقصد را routing (مسیریابی) میگویند
عملیات routing در لایه سوم (network layer) از مدل OSI صورت میگیرد

Routing Table (جدول مسیریابی)
به جدولی از اطلاعات که مسیرهای مورد نیاز برای هدایت بسته ها به نقاط مختلف شبکه های مختلف را در اختیار سخت افزار شبکه (مسیریابها)میگذارد گفته میشود
جدول مسیریابی به محض دریافت اطلاعات جدید به روز رسانده میشود

Routed Protocols
routed protocols پروتکل لایه شبکه  است که  برای انتقال ترافیک بین شبکه ها استفاده میشود به عنوان مثال ip,ipx

Routing Protocols
 بوسیله روترها برای عوض کردن اطلاعات routing table استفاده میشوند بعنوان مثال RIP,IGRP

سه نوع مختلف routing

1.default routing
2.static routing
3.dynamic routing

  • Default Route

default Route برای شیکه هایی که مقصدشان نامشخص است پیکربندی میشود
سیستم کار default به اینصورت است که اطلاعات به روتر فرستاده میشود اگر متعلق به آن نبود آن اطلاعات را به روتر بعدی تحویل میدهد

 

  • Static Route

Static بوسیله administrator بصورت دستی برای مقصد مشخص در شبکه پیکربندی میشود

Static Routing برای شبکه های کوچک مناسب میباشد

 

  • Dynamic Route

در Dynamic Routing از پروتوکلها به منظور یافتن مسیر  و update کردن routing table استفاده میشود و برای شبکه های بزرگ مناسب میباشد
پروتکلها عبارتند از

1.RIP(Routing Information Protocol)
2.IGRP(Interior Gatway Routing Protocol)
3.EIGRP(Enhanced Interior Gatway Routing Protocol)
4.OSPF(Open Shortest Path First)

 


پیکربندی Default Routing
در این دوره از سناریوی زیر برای تمرین و فهم مطالب استفاده میکنیم

Default Routing پبکربندی

قبل از شروع به configure کردن بهتر است مقداری توضیح درباره شکل بالا بدم
RA,RB,RC اسم روترها هستند تا این لحظه از اسم Router که بصورت پیشفرض بر روی روتر بود استفاده میکردیم.بوسیله فرمان hostname میتوانیم اسم روتر را تغییر دهیم و برای این استفاده میشود که روترها را راحتتر تشخیص دهیم

 

Router(config)#hostname RA
RA(config)#

 

s0,s1 همان Serial interface است .در این interface روترها را بوسیله Cross over cable بهم متصل میکنیم
e0 همان ethernet interface است.در این interface روتر و switch بهم متصل میشوند
شکل فوق در نگاه اول شاید یک مقدار گیچ کننده باشد به همین دلیل بصورت مجزا اطلاعات هر روتر را در زیر قرار میدهم

RA
s0-->120.120.120.1
e0-->192.168.10.1
pc1-->192.168.10.2
pc2-->192.168.10.3
pc3-->192.168.10.4

RB
s1-->120.120.120.2
s0-->150.150.150.1
e0-->192.168.20.1
pc1-->192.168.20.2
pc2-->192.168.20.3
pc3-->192.168.20.4

RC
s1-->150.150.150.2
e0-->192.168.30.1
pc1-->192.168.30.2
pc2-->192.168.30.3
pc3-->192.168.30.4

Default Route
از syntax زیر برای default routing استفاده میکنیم

RA(config)#ip route Destination network address subnet Default Gatway

دو نکته در اینجا لازم به تذکر است.اول اینکه همانطور که گفته شد default route برای آدرسهای نامشخص تعیین میشود به همین دلیل آدرس مقصد(Destination address)را 0.0.0.0 میدهیم.
نکته دوم اینکه برای هر روتر آدرسهایی را که مستقیم به روترما وصل شده اند مسیریابی میکنیم.توچه داشته باشید تمامی اعمال بوسیله console cable که در console port قرار میگیرد صورت میگیرد

حال موقع آن رسیده از تمامی مواردی که یاد گرفتیم استفاده کنیم
برای درک بهتر, تنظیمات هر روتر را بطور کامل و جدا از هم انجام میدهم.توجه داشته باشید که قبل از عملیات routing باید تمام interface ها را تعیین کنیم سپس مسیر دهی کنیم


RA>en
RA#config t
RA(config)#int e0
RA(config-if)#ip address 192.168.10.1 255.255.255.0
RA(config-if)#no shut
RA(config-if)#^z
RA(config)#wr

RA#config t
RA(config)#int s0
RA(config-if)#ip address 120.120.120.1 255.0.0.0
RA(config-if)#clock rate 64000
RA(config-if)#no shut
RA(config-if)#^z
RA(config)#wr

RA(config)#ip route 0.0.0.0 0.0.0.0 120.120.120.2
RA(config)wr


RB>en
RB#config t
RB(config)#int e0
RB(config-if)#ip address 192.168.20.1 255.255.255.0
RB(config-if)#no shut
RB(config-if)#^z
RB(config)#wr

RB#config t
RB(config)#int s1
RB(config-if)#ip address 120.120.120.2 255.0.0.0
RB(config-if)#clock rate 64000
RB(config-if)#no shut
RB(config-if)#^z
RB(config)#wr

RB#config t
RB(config)#int s0
RB(config-if)#ip address 150.150.150.1 255.255.0.0
RB(config-if)#clock rate 64000
RB(config-if)#no shut
RB(config-if)#^z
RB(config)#wr
RB(config)#ip route 0.0.0.0 0.0.0.0 120.120.120.1
RB(config)#ip route 0.0.0.0 0.0.0.0 150.150.150.2
RB(config)#wr

RC>en
RC#config t
RC(config)#int e0
RC(config-if)#ip add 192.168.30.1 255.255.255.0
RC(config-if)#no shut
Rc(config-if)#^z
RC(config)#wr

RC#config t
RC(config)#int s0
RC(config-if)#ip add 150.150.150.2 255.255.0.0
RC(config-if)#clock rate 64000
RC(config-if)#no shut
RC(config-if)#^z
RC(config)#wr

RC(config)#ip route 0.0.0.0 0.0.0.0 150.150.150.1
RC(config)#wr

برای دید routing table از فرمان زیر استفاده میکنیم
اگر به table توجه کنید جلوی بعضیip ها c گذاشته شده است و این به معنی directly connected است یعنی مستقیما نصب شده اند میباشد
همچنین جلوی بعضیها *S و به معنیDefault میباشد

RA#sh ip route

همچنین برای دیدن interfaceها

RA#sh ip int brief